Flowers

Bouquet of white orchid blooms!

2019-06-08 18:15 #0 by: Evelina

I’m so proud that I was able to keep this orchid alive and have it bloom after a year of owning it!

It was much more low maintenance than I thought 😊

Do you have any orchids in bloom? 🌸

Report
2019-06-08 20:41 #1 by: Maleficum

My mum have a lot of them and there is always a few of them blooming (when they stop she just put them behind the curtains and usually the once standing there are starting to bloom so she put them in the middle of the window), she also gets a lot of baby plants on them (one time the baby plant started blooming).

Sadly they don't like living in my home (even if mum and I do the exact same things taking care of them) and always starts dying (then I give them to mum and they perk right up again).

But I recently discovered that they do well if I put them on the edge of my aquarium and letting some of the roots go down in the water and they get the light from the aquarium so hopefully I can get to have some blooming!

(sadly I cant get the pictures to work :()

Report
2019-06-09 07:56 #2 by: Evelina

My grandma was really good at caring for them. She did the same, putting the ones not in bloom behind the curtains 😊 Very good idea!

I found a corner for my three orchids that doesn’t get too much sun, and it’s indirect all the time, since it’s facing away from where the sun is. I think they like it. A family member gave me theirs because they moved out of the country and it bloomed a couple weeks after I had it! It had previously been burnt by a candle incident at their place so they were surprised to hear it bloomed.

My tiny baby one has not bloomed again though. It might now like the container it’s in. I’ll take a pic and show you.

That sounds interesting with the aquarium! Hope the pictures work for you soon. 😕

Report
2019-06-10 12:17 #3 by: Leia

In love I don't own any orchids but they sure are pretty!

All the best, Leia

Host of  Gluten-Free Living | News  | English Language Heart

Report
2019-06-10 14:07 #4 by: Maleficum
result

Still can't get the pictures to work :(

Report
2019-06-12 08:41 #5 by: Niklas

I can't count all the orchids we have killed. I agree they are good looking though.

#4: If you send the image to me (niklas at savvity.net), I can take a look at it and try to find out what is wrong. It may be in the wrong format or too large.

Report
2019-06-12 20:48 #6 by: Maleficum
result

#5 It appears that I can't post any pictures at all (have no problem with the same pictures at Ifokus)

(it's this picture I'm trying for)

Report
2019-06-14 05:27 #7 by: Niklas

That's interesting. The photo in your link is 9 megabyte. The size limit is 5 megabyte. Did you use the desktop or mobile version when you posted the photo at iFokus?

If you shrink the photo size it will be uploadable here as well.

Report
2019-06-14 23:14 #8 by: Maleficum

#7 Only use the computer (don't like surfing on the phone).

Report
2019-06-15 10:52 #9 by: Niklas

I can't explain how that was possible. It may be that you're using an unusual browser.

Report
2019-06-15 15:04 #10 by: Maleficum

#9 Always used Firefox, and never have problem posting images on Ifokus and I don't think I've had previous problems posting here on Savity. Very strange.

Report

There is anohter comment in this discussion. It is, however, only visible for logged in members. To read the comment, log in or register to become a member.